Nada más revisar el correo, me entero que el equipo de desarrolladores de Asterisk acaba de publicar la primera versión oficial del famoso DAHDI que tanto ha dado que hablar.

Entra aquí para conocer más información sobre DAHDI.

En la lista de paquetes publicado hoy se encuentran estos:

dahdi-linux 2.0.0

Este paquete DAHDI-LINUX contiene los módulos de kernel necesario para poder utilizar las tarjetas de comunicaciones.

dahdi-tools 2.0.0

Las DAHDI-TOOLS son las aplicaciones necesarias para cargar la configuración hacer tests a algunas tarjetas, y algunas cosas más que se irán añadiendo poco a poco.

dahdi-linux-complete 2.0.0+2.0.0

El paquete DAHDI-LINUX-COMPLETE es la unión de los dos anteriores, para no tener que descargar dos paquetes independientes.

El modo de compilación es tan sencillo como siempre lo ha sido el Zaptel:

cd /usr/src
wget -c http://downloads.digium.com/pub/telephony/dahdi-linux-complete/dahdi-linux-complete-2.0.0+2.0.0.tar.gz
tar xvfz dahdi-linux-complete-2.0.0+2.0.0.tar.gz
cd dahdi-linux-complete-2.0.0+2.0.0
make
make install
make config

Una vez hecho esto, nos encontraremos con algunos cambios importantes.

Para empezar, los módulos para las tarjetas ya no se encuentran en el directorio:
/lib/modules/2.6.XX-X-XXX/misc

si no que se encuentran en un nuevo directorio:
/lib/modules/2.6.XX-X-XXX/dahdi

En este directorio nos encontraremos con algunos módulos conocidos para tarjetas como el wctdm24xxp, wctdm, wcte11xp, wcte12xp, e incluso el pciradio y el xpp.

Pero también nos encontraremos con otros nuevos:

dahdi.ko (que sustituye al zaptel.ko)
dahdi_dynamic*.ko (que sustituye al ztdynamic, al ztd_eth y al ztd_ethmf)
dahdi_transcode.ko (que sustituye al zttranscode)
dahdi_dummy.ko (que sustituye al ztdummy)
y lo más novedoso:
dahdi_echocan_XXX.ko (completamente nuevos y son los canceladores de eco software que ahora pueden ser cargados y descargados sin necesidad de recompilar el zaptel)

Para iniciar el DAHDI, tan solo tenemos que reiniciar el sistema, o bien iniciar el servicio:

asterisk# /etc/init.d/dahdi start
Loading DAHDI hardware modules:
wct4xxp: error   wcte12xp: error   wct1xxp: error   wcte11xp: error   wctdm24xxp: error   wcfxo: error   wctdm: error   xpp_usb: done

No hardware timing source found in /proc/dahdi, loading dahdi_dummy
Running dahdi_cfg: done.

Facil ¿verdad?

Eso sí, DAHDI solo es compatible con versiones de Asterisk 1.4.22 o superior y Asterisk 1.6.0 o superior, versiones inferiores abstenerse. 😛

Continuar con la lista de cambios…

2 Comentarios

Archivos

© 2014 Sinologic, inc. All rights reserved.

Menú

Redes sociales